...

Go Back   Lateral-g Forums > Technical Discussions > Engine
User Name
Password



Reply
 
Thread Tools Display Modes
  #1  
Old 06-25-2017, 04:59 PM
WicKeD_SS's Avatar
WicKeD_SS WicKeD_SS is offline
Senior Member
 
Join Date: Feb 2006
Location: Vincennes, IN
Posts: 360
Thanks: 0
Thanked 0 Times in 0 Posts
Default Electric fuel pump shuts off??!

Im having an issue with my areomotive ss pump https://m.summitracing.com/parts/aei...UuYhoCaKPw_wcB . I was driving yesterday and the car all of the sudden started to lose power then died. I noticed the fuel pump wasn't running. I turned the key a few times and the pump started running. Worried i started heading home i pulled in the driveway and it did it again! I have no idea why the pump just shuts off, it was a cool 80 degree day and im running a retuen line so i dont think its over heating. Any thoughts? Maybe pumps going bad?? Any help would be appreciated!
__________________
WicKeD
Reply With Quote
  #2  
Old 06-28-2017, 06:36 PM
66fury's Avatar
66fury 66fury is offline
Senior Member
 
Join Date: Feb 2013
Posts: 216
Thanks: 0
Thanked 0 Times in 0 Posts
Default

maybe relay going bad or wiring too small
__________________
mark
Reply With Quote
  #3  
Old 06-29-2017, 09:51 AM
andrewb70's Avatar
andrewb70 andrewb70 is offline
Senior Member
 
Join Date: Jul 2005
Posts: 508
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Double check all the wiring. Something may just be loose.

Andrew
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:11 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright Lateral-g.net