...

Go Back   Lateral-g Forums > Technical Discussions > Chassis and Suspension
User Name
Password



Reply
 
Thread Tools Display Modes
  #1  
Old 09-15-2021, 03:37 PM
vet57air's Avatar
vet57air vet57air is online now
Member
 
Join Date: Feb 2021
Location: West coast Canada
Posts: 90
Thanks: 33
Thanked 97 Times in 44 Posts
Default GM type 2 power steering

Bought a front drive kit for my LT4 from Drive Junky. Power steering had a little more effort than I liked. Called Zach and he said the GM type 2 pump that he supplies has a valve in it that supplies about 2 GPM suitable for Mustang 2 Suggested I get one for 3 GPM for my 80's T bird rack. So bought the black one off summit but only goes in part way before it gets very hard to turn. Threads appear the same. The only difference between the two seems to be the main body port size. .150 for the black to .125 for the silver. Thinking I may just drill out my original. In my inspection I noticed on the original the small port just above the "O" ring goes through on the new black unit but not on my original silver one. Was going to drill it all the way but it just a bit smaller than 1/16".
Anyone have any experience with these?
Name:  20210915_125904.jpg
Views: 0
Size:  85.9 KB

Last edited by vet57air; 09-15-2021 at 03:40 PM.
Reply With Quote
  #2  
Old 09-15-2021, 07:47 PM
zz430droptop67rs's Avatar
zz430droptop67rs zz430droptop67rs is online now
Senior Member
 
Join Date: Jan 2014
Location: Houston, Texas
Posts: 240
Thanks: 117
Thanked 51 Times in 32 Posts
Default

It has been over 10 years ago, but I changed out the valve in a DSE type II pump and I was also running an 84 T-bird rack. With wide tires the effort was high. After the change I noticed zero difference.

Sorry I can't help with part #'s it's been so long ago. I'm just saying the result was disappointing.
Reply With Quote
The Following 2 Users Say Thank You to zz430droptop67rs For This Useful Post:
rebob (09-19-2021), vet57air (09-15-2021)
  #3  
Old 09-16-2021, 05:41 PM
vet57air's Avatar
vet57air vet57air is online now
Member
 
Join Date: Feb 2021
Location: West coast Canada
Posts: 90
Thanks: 33
Thanked 97 Times in 44 Posts
Default

So I found another pump out of a 2000 vette and pulled the valve. It was pretty much identical my original. The small hole above the "O" ring did not go all the way through also. All three valves screw into the newest pump. Can't figure why the summit unit won't go all the way in my pump. Drilled out my original valve and reinstalled. We will see if any difference.
Reply With Quote
The Following User Says Thank You to vet57air For This Useful Post:
zz430droptop67rs (09-16-2021)
  #4  
Old 09-27-2021, 11:47 AM
zz430droptop67rs's Avatar
zz430droptop67rs zz430droptop67rs is online now
Senior Member
 
Join Date: Jan 2014
Location: Houston, Texas
Posts: 240
Thanks: 117
Thanked 51 Times in 32 Posts
Default

Any updates?
Reply With Quote
  #5  
Old 10-07-2021, 07:42 AM
UMI Tech's Avatar
UMI Tech UMI Tech is offline
Member
 
Join Date: Dec 2014
Location: Central PA
Posts: 70
Thanks: 2
Thanked 8 Times in 6 Posts
Default

For flow rate and valving questions I've always had good luck with Turn One's tech advice.
Reply With Quote
The Following User Says Thank You to UMI Tech For This Useful Post:
camcojb (10-07-2021)
  #6  
Old 03-24-2022, 06:26 PM
vet57air's Avatar
vet57air vet57air is online now
Member
 
Join Date: Feb 2021
Location: West coast Canada
Posts: 90
Thanks: 33
Thanked 97 Times in 44 Posts
Default

Quote:
Originally Posted by zz430droptop67rs View Post
Any updates?
Getting warmer and the roads are a little cleaner, so took out the Cgt for a drive. No issues at first, but once warmed up when not moving I could not turn the wheel. So worse than before.
Reply With Quote
The Following User Says Thank You to vet57air For This Useful Post:
zz430droptop67rs (03-24-2022)
  #7  
Old 03-25-2022, 04:36 PM
vet57air's Avatar
vet57air vet57air is online now
Member
 
Join Date: Feb 2021
Location: West coast Canada
Posts: 90
Thanks: 33
Thanked 97 Times in 44 Posts
Default

Have chatted with Jeff from Turn one steering. He has given me a lot of good info. He guesses that the pump is toast. Mine is the non-oem GM type 2 pump that Drive Junky supplied with the rest of the drive system. Tried to go to Drive Junky's web site today and it says "account suspended"?

Last edited by vet57air; 03-28-2022 at 04:28 PM.
Reply With Quote
  #8  
Old 03-29-2022, 10:47 AM
vet57air's Avatar
vet57air vet57air is online now
Member
 
Join Date: Feb 2021
Location: West coast Canada
Posts: 90
Thanks: 33
Thanked 97 Times in 44 Posts
Default

Drive Junky web site is back up and I have conversed with Zach by email.
Reply With Quote
  #9  
Old 03-30-2022, 09:03 AM
Ketzer's Avatar
Ketzer Ketzer is offline
Lateral-g Supporting Member
 
Join Date: Feb 2008
Location: Eads, TN.
Posts: 1,359
Thanks: 150
Thanked 101 Times in 73 Posts
Default

Hope you'll follow up and let us know what happened.
These kinds of gremlins always pop up and your experience with it is of huge value to the community.


Jeff-
__________________
You remind me of the timing on a turbo engine...
Reply With Quote
The Following User Says Thank You to Ketzer For This Useful Post:
camcojb (04-04-2022)
  #10  
Old 04-04-2022, 10:11 AM
67-ls1 67-ls1 is offline
Junior Member
 
Join Date: Jan 2021
Posts: 16
Thanks: 6
Thanked 22 Times in 7 Posts
Default

Following…
__________________
1966 Chevelle with 217 ci, 4 cam V6, 6 speed auto, full Hotchkis suspension, Wilwood discs all around. Built for smooth, quiet handling and max MPG.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:17 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright Lateral-g.net