...

Go Back   Lateral-g Forums > Technical Discussions > Safety Equipment
User Name
Password



 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 02-13-2016, 08:05 PM
Mike69Cam Mike69Cam is offline
Junior Member
 
Join Date: Dec 2009
Location: Thousand Oaks, CA
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Fuelabs pump issues

I own a '66 Chevelle with an LS3 bottom end, LS9 top end...It makes about 750 HP with 650LB torque. I drive this car usually 50-75 miles on the weekend. I don't race it anymore. We recently installed an ATL fuel cell and new fuel lines (wider gauge) to accommodate the HP. The pump is out side of the tank and has returns lines. The Fuelab pump is rated at 1000 HP and above. Under normal driving, it makes a lot of noise, which I hear is normal. When I run low on fuel from time to time, it cavitates...I then have to add fuel and then wait for air to leave the pump. Occasionally when tank is like 3/4 full, it will suck in air and I am on the side of road for 20-30 mins waiting for air to leave pump.

Question-Are these fuel pumps made for long drives? Is there a better brand that runs quieter and more reliably on longer drives?
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright Lateral-g.net