...

Go Back   Lateral-g Forums > Technical Discussions > EFI and Forced Induction
User Name
Password



Reply
 
Thread Tools Display Modes
  #1  
Old 02-05-2019, 10:51 AM
hdduramaxman hdduramaxman is offline
Junior Member
 
Join Date: Dec 2018
Posts: 19
Thanks: 5
Thanked 3 Times in 3 Posts
Default whipple intercooler setups in 1st gen camaros

Lets see how you guys installed your intercooler systems in your 1st gen camaros. What brand parts did you use and how did you route your cooling lines..... Post pics



Thanks
Reply With Quote
  #2  
Old 09-05-2019, 08:59 PM
732ndgen 732ndgen is offline
Senior Member
 
Join Date: Mar 2008
Posts: 139
Thanks: 1
Thanked 0 Times in 0 Posts
Default intercooler

[attach]1969_Chevrolet_Camaro_DJ_2019-07-25_0016.jpg[/attach]
Attached Images
File Type: jpg 1969_Chevrolet_Camaro_DJ_2019-06-14_0020.jpg (128.7 KB, 0 views)
Reply With Quote
  #3  
Old 09-05-2019, 10:40 PM
Dave95z28 Dave95z28 is offline
Senior Member
 
Join Date: Apr 2005
Posts: 127
Thanks: 0
Thanked 4 Times in 3 Posts
Default

Is that whole stack all Autorad? I have their radiator and core support I bought from some one before getting a LSA and I was thinking about getting their heat exchanger. What’s the small one up top? Transmission or Oil?
Reply With Quote
  #4  
Old 09-07-2019, 08:12 AM
jmac jmac is offline
Senior Member
 
Join Date: Mar 2008
Location: Howell, NJ
Posts: 110
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Man that Autorad setup looks killer. Love the car, nice work!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:35 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright Lateral-g.net