...

Go Back   Lateral-g Forums > Technical Discussions > EFI and Forced Induction
User Name
Password



Reply
 
Thread Tools Display Modes
  #1  
Old 06-05-2021, 08:25 PM
RdHuggr68 RdHuggr68 is offline
Senior Member
 
Join Date: Jan 2009
Location: Elizabeth CO
Posts: 655
Thanks: 152
Thanked 15 Times in 11 Posts
Default Noisy Walbro pump

I have a Walbro pump in my Tanks Inc tank. The pump is very loud and I know I saw a few posts on here on a pump that performs better and is quiet. I am running a LS3 525hp.
Thank you
Reply With Quote
  #2  
Old 06-06-2021, 12:52 PM
RdHuggr68 RdHuggr68 is offline
Senior Member
 
Join Date: Jan 2009
Location: Elizabeth CO
Posts: 655
Thanks: 152
Thanked 15 Times in 11 Posts
Default

I know I have seen discussions about this issue in the past year and what pumps they were going to replace the Walbro with. I searched and can't find it, I think they were using Bosch but nit sure. Any help would be appreciated.
Reply With Quote
  #3  
Old 06-06-2021, 05:13 PM
Bad Bowtie Bad Bowtie is offline
Senior Member
 
Join Date: Apr 2006
Location: Central Florida
Posts: 206
Thanks: 3
Thanked 14 Times in 12 Posts
Default

Wow this is not news I wanted to hear, I just received my Tanks Inc gas tank yesterday complete with a Walbro pump and I fit it to the tank this morning. Unfortunately I wont be able to find out till many months from now as I am still assembling a full on restoration. Guess I will keep this in my notes of things to look out for.
Just wonder are you running PWM pump?

BB
Reply With Quote
  #4  
Old 06-07-2021, 08:58 PM
RdHuggr68 RdHuggr68 is offline
Senior Member
 
Join Date: Jan 2009
Location: Elizabeth CO
Posts: 655
Thanks: 152
Thanked 15 Times in 11 Posts
Default

Quote:
Originally Posted by Bad Bowtie View Post
Wow this is not news I wanted to hear, I just received my Tanks Inc gas tank yesterday complete with a Walbro pump and I fit it to the tank this morning. Unfortunately I wont be able to find out till many months from now as I am still assembling a full on restoration. Guess I will keep this in my notes of things to look out for.
Just wonder are you running PWM pump?

BB
Not running a PWM pump.
Reply With Quote
  #5  
Old 06-08-2021, 07:37 AM
dontlifttoshift's Avatar
dontlifttoshift dontlifttoshift is online now
Senior Member
 
Join Date: Oct 2012
Location: Beach Park. IL
Posts: 868
Thanks: 6
Thanked 93 Times in 58 Posts
Default

Andrew did a video of swapping the walbro for a Deatschwerks pump and it was much quieter. I did the same on my car, without the video, and it is much quieter.

I try not to buy Walbro pumps anymore.

I used part number 9-201-1000 I dont' remember what Andrew used.
__________________
Donny

Support your local hot rod shop!
Reply With Quote
The Following 4 Users Say Thank You to dontlifttoshift For This Useful Post:
andrewb70 (06-11-2021), Bad Bowtie (06-09-2021), dhutton (06-08-2021), RdHuggr68 (06-08-2021)
  #6  
Old 06-09-2021, 02:26 PM
214Chevy's Avatar
214Chevy 214Chevy is offline
Lateral-g Supporting Member
 
Join Date: Jul 2008
Location: Good, Ole Texas
Posts: 4,333
Thanks: 56
Thanked 388 Times in 242 Posts
Default

Well, I'm gonna be in trouble then....I have twin Walbro's in my tank.
__________________
'68 C10 swb
'69 Camaro convertible
'72 Chevelle

Reply With Quote
  #7  
Old 06-09-2021, 04:56 PM
dhutton dhutton is online now
Senior Member
 
Join Date: Nov 2006
Location: Mountain Springs, Texas
Posts: 1,713
Thanks: 601
Thanked 206 Times in 136 Posts
Default

Quote:
Originally Posted by 214Chevy View Post
Well, I'm gonna be in trouble then....I have twin Walbro's in my tank.
Your Vaporworx PWM controller should keep them quiet imho….

Don
Reply With Quote
  #8  
Old 06-09-2021, 05:35 PM
214Chevy's Avatar
214Chevy 214Chevy is offline
Lateral-g Supporting Member
 
Join Date: Jul 2008
Location: Good, Ole Texas
Posts: 4,333
Thanks: 56
Thanked 388 Times in 242 Posts
Default

Quote:
Originally Posted by dhutton View Post
Your Vaporworx PWM controller should keep them quiet imho….

Don
Thanks Don...that's good to know.
__________________
'68 C10 swb
'69 Camaro convertible
'72 Chevelle

Reply With Quote
  #9  
Old 06-11-2021, 11:55 AM
andrewb70's Avatar
andrewb70 andrewb70 is offline
Lateral-g Supporting Vendor
 
Join Date: Jul 2005
Posts: 656
Thanks: 28
Thanked 72 Times in 52 Posts
Default

Quote:
Originally Posted by dontlifttoshift View Post
Andrew did a video of swapping the walbro for a Deatschwerks pump and it was much quieter. I did the same on my car, without the video, and it is much quieter.

I try not to buy Walbro pumps anymore.

I used part number 9-201-1000 I dont' remember what Andrew used.


Andrew
__________________
Instagram @projectgattago
I offer remote Holley EFI tuning.
I deliver what EFI promises.
Please get in touch if I can be of service.
My YouTube Channel
Reply With Quote
The Following 3 Users Say Thank You to andrewb70 For This Useful Post:
68454RS (07-28-2021), RdHuggr68 (06-11-2021), zz430droptop67rs (06-11-2021)
  #10  
Old 07-20-2021, 08:12 AM
takid455 takid455 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 252
Thanks: 0
Thanked 5 Times in 5 Posts
Default

My 255 was noisy. The 450 I have now is not.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:24 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright Lateral-g.net